cPanel

How to Fix ‘To re-install the application please uninstall the existing installation!’ in App Installer

When you try to install a new app in Ecenica App Installer you see an error message:

‘To re-install the application please uninstall the existing installation!’

This error usually occurs when there are remnants of a previous installation in the directory where you’r trying to install a new application. Here are the steps to resolve this issue:

Steps to fix ‘To re-install the application please uninstall the existing installation!’

  1. Log in to cPanel.
  2. Click File Manager.
  3. click on the public_html folder to see all folders and files inside it.
  4. In the upper right corner, click on Settings.
  5. Tick the checkbox for Show Hidden Files.
  6. Click Save, and you’ll be back to the public_html folder.
  7. Above the list of your folders and files in the public_html folder, tick the checkbox for Select All.
  8. Click Delete.
  9. Now, all files inside the public_html folder will be deleted, including the hidden files.
  10. Go back to Ecenica App Installer and try installing your app again.

Was this guide helpful?

Need help with this?

Open a ticket and link to this guide so our team can see what you have tried.

View support tickets

Power your business with Ecenica Hosting

Built for WordPress and serious websites. Fast, secure and supported by real people in the UK.

Ecenica hosting services represented by a connected red route across London