Problem
When you send an email, the following error can occur:
Domain example.com has exceeded the max defers and failures per hour (30/30 (100%)) allowed. Message discarded.
Symptom
- Sending email from any of your Ecenica email accounts fails
- You receive a Non-Delivery Report (NDR) with the error shown above.
Cause
Your account has exceeded the allowed number of bounced messages per hour and as a result your sending rights have been blocked.
The block is temporary and is removed on the hour. For example, if it’s 10:30 AM then the block will be removed at 11 AM.
This block is required to prevent your account from being permanently blocked by third party mail servers and spam blacklists.
Resolution
The block will be automatically removed on the hour. Please wait till an hour has passed to attempt to send email again.
Prevention
To prevent max defers and failures per hour error messages please check the following:
Use the Track Delivery tool to find out why emails are failing.
Common causes of delivery failures include:
- A compromised mailbox sending spam: If you see a large number of delivery failures from one of your email addresses then we recommend immediately changing the mailbox password and virus scanning all your devices.
- Autoresponders: This block can sometimes be triggered when you have an autoresponder setup to send an out-of-office reply to all emails you receive. This is because the autoresponder will reply to all emails including spam email addresses which do not exist. In these cases the reply will fail which counts towards the delivery failure count per hour on your domain. To resolve this ensure your Spam Filters are enabled on your Ecenica hosting account. This will ensure emails we flag as spam are not sent an autoresponse.
- Out of date email forwarders. If you are forwarding email sent to another mailbox then check the forwarder email account is still valid and is receiving emails OK. If we attempt to forward an email to an address which no longer exists and is not accepting email then it will count as a delivery failure. Check your Email Forwarders
- Mailing lists which are out of date. If you are sending a mass marketing email, please check your mailing list is up to date by removing email addresses which no longer work. Sending to multiple invalid email addresses will trigger the block. The only way to resolve this is to clean your mail list and remove email addresses which result in bounce-backs.
- Check your mailboxes have free space. Mailboxes which have reached their storage quota and cannot accept emails will cause delivery failures. To fix, you can manage increase your mailbox quota. You can also delete old emails to reduce your mailbox usage.